Linux gaming

Posts you want to find years later go here.

Postby Jonathan » Wed Nov 30, 2005 7:37 pm

I upgraded this summer from Debian sarge to etch. As part of this transition, I have upgraded from Xfree86 to X.org and from the custom 2.6.8 kernel I built to the 2.6.12-1-686 kernel provided by etch. As a result of the kernel transition, I was able to install the Debian NVidia drivers with a minimum amount of hassle. I still have to fix the symlinks to the libGL libraries for some unknown reason. As compensation, I found the documentation on how to suppress the NVidia splash screen when my X server starts.

In contrast to my old kernel, ALSA just works with the new kernel. I am much more pleased by etch than sarge.

I have been very pleased by the Debian testing distribution. I dislike running unstable because every so often something gets uploaded into unstable that breaks just about everything. This really hasn't happened with testing. I decided to upgrade my kernel and X server simultaneously, which was the most painful part of running Debian testing so far.

Etch is also testing a new GUI installer that looks very promising.
Last edited by Jonathan on Wed Nov 30, 2005 9:09 pm, edited 1 time in total.
Jonathan
Grand Pooh-Bah
 
Posts: 5943
Joined: Tue Sep 19, 2006 7:45 pm
Location: Portland, OR

Postby Jonathan » Wed Nov 30, 2005 9:06 pm

Dwindlehop wrote:I can play DivX, MPEG, and WMV with the default setup of Totem and/or VLC with no issues. WMV 9 isn't supported yet, but I understand DVD Jon has a proof of concept out already.

This is largely incorrect. Mplayer can play WMV3 (the WMV 9 codec) right now, but only through a wrapper around the Win32 dll. Obviously, this only works on x86 machines. An OSS implementation is still not yet available.

The reason I didn't know this earlier is mplayer is not in Debian, for various lingering copyright issues. I don't know if mplayer will make it into next year's (ha!) etch release or not.

I found this out because I filmed some ducks at the zoo with my Canon SD200. When I dumped the .avi to my computer (thanks gphoto2!), the sound was terrible. Apparently there's some kind of bug with the audio decoding in VLC and Totem. I wanted to try mplayer, but couldn't find it because it isn't in Debian. There are unofficial Debian packages for mplayer and its various codecs, but they won't install on etch at the moment. I pinged the package maintainer, who said that the etch version was blocked on libquicktime, which has been trying to get into testing for 84 days while waiting on gcc and binutils bugs. Sigh.
Jonathan
Grand Pooh-Bah
 
Posts: 5943
Joined: Tue Sep 19, 2006 7:45 pm
Location: Portland, OR

Postby Jonathan » Sun Jan 01, 2006 6:54 pm

Dwindlehop wrote:Well, they don't package it, not really. But hey, it's there, complete with five year old bugs.

I feel obligated to report that since March, a new maintainer has taken over the package and a new version of GFingerpoken has finally made its way into testing. So they do package this game, and they've cleared out the bugs.
Jonathan
Grand Pooh-Bah
 
Posts: 5943
Joined: Tue Sep 19, 2006 7:45 pm
Location: Portland, OR

Postby Jonathan » Mon Feb 13, 2006 11:07 pm

I googled for some time without finding a way to fix my problem with installing Eve Online. After a bit of experimenting I finally found a workaround, namely using Wine to install and Cedega to play.
Jonathan
Grand Pooh-Bah
 
Posts: 5943
Joined: Tue Sep 19, 2006 7:45 pm
Location: Portland, OR

Postby Jonathan » Thu Jun 01, 2006 4:50 pm

The newer versions of Cedega (>=5.1.1) fix issues with Minmater gates and the Escape key menu in Eve. I installed it this week because my corp is moving to Minmater space. Now I can change the resolution, finally.

I have had Eve lock up X once. It still has not locked up the machine altogether.
Jonathan
Grand Pooh-Bah
 
Posts: 5943
Joined: Tue Sep 19, 2006 7:45 pm
Location: Portland, OR

Postby Jonathan » Thu Jun 01, 2006 5:04 pm

Also, I fixed the error I was getting with Nvidia drivers not symlinking to the correct object files by installing nvidia-glx-dev. This is a known bug with the Debian package.
Jonathan
Grand Pooh-Bah
 
Posts: 5943
Joined: Tue Sep 19, 2006 7:45 pm
Location: Portland, OR

Postby Jonathan » Mon Jun 26, 2006 9:16 pm

Etch recently moved to X.org 1.7.0. After a great deal of fiddling around with the maintainer's private repository and trying to get nvidia-glx installed, I deleted the Debian packages and installed the drivers straight from NVidia. I believe having both sets of drivers around was what was confusing my object symlinks previously. I think I'll stay with the vendor distribution for a while. The Debian release philosophy doesn't really comprehend the concept of 3D graphics drivers.

A quick note: the simple way to get the Nvidia driver installer to compile an interface for your kernel is to run `m-a prepare` before you do the installation, at least on Debian. Also run the installer using `--x-module-path=/usr/lib/xorg/modules/` to make it work under X.org 1.7.0. And finally in Etch the default version of gcc is 3.3 but the kernel is compiled with 4.0 so you want:
Code: Select all
% m-a prepare
% CC=gcc-4.0 sh NVIDIA_installer.sh --x-module-path=/usr/lib/xorg/modules/
Jonathan
Grand Pooh-Bah
 
Posts: 5943
Joined: Tue Sep 19, 2006 7:45 pm
Location: Portland, OR

Postby Jonathan » Mon Dec 03, 2007 10:23 pm

Envy - http://albertomilone.com/nvidia_scripts1.html - a script for installing Nvidia's driver automagically on Ubuntu

I'm definitely going to give Ubuntu a whirl soon.
Jonathan
Grand Pooh-Bah
 
Posts: 5943
Joined: Tue Sep 19, 2006 7:45 pm
Location: Portland, OR

Previous

Return to The Vault

Who is online

Users browsing this forum: No registered users and 1 guest

cron